Update About Spectre and Meltdown Security Flaws

Spectre and Meltdown security Flaws in Most Modern Devices

I am sure many of you will have heard that there are security flaws in Intel, AMD and ARM processors – called Spectre and Meltdown. Spectre affects all modern processors, whereas Meltdown affects Intel, plus Itanium and Atom chips made before 2013. Potentially these flaws could enable hackers to steal passwords and sensitive data from ANY device made in the last 20 years that has a processor. Note this includes Apple devices – see link at bottom of page for which versions have been issued ‘mitigations’ (in Apple speak).

Read moreUpdate About Spectre and Meltdown Security Flaws